$re = '/.+?(?=(?:&#|$))/m';
$str = 'I am the cff5cComputer cee4cMan';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);