import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\d+(?:[,.]\\d+)?\\s?\\/\\s?\\d+(?:[,.]\\d+)?(?=\\s?x))(\\d+(?:[,.]\\d+)?)\\s?\\/\\s?(\\d+(?:[,.]\\d+)?)";
final String string = "dummy word 222/2334; Ø14 x Ø6,33/523,23 x 2311 mm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}