$re = '/\w{1}:\/\/([a-zA-Z0-9\-\_\s]+\/)*\w+\.\w+/m';
$str = 'c://program files/system32/data.dat
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);