$re = '/^[0-9a-zäöüÄÜÖß \/:\(\),\'\.-]*$/i';
$str = 'Test NameäöüÄÖÜß/:,.-\'Bob with 0123456789';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);