package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:.*)(?:{"id":)(\d+)(?:.*)$`)
var str = `{"user":{"id":111111,"userName":`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}