#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iu)(?:Расположение|\G(?!\A)).*?([а-яё][\s\.\,\-а-яё]*[а-яё])"
Local $sString = "<div class="line-tit">Цена</div><div class="line-val"><span class="price-more"><span class="price-more-list"><i>5 950 000 ₽</i><i>80 297 $</i><i>67 818 €</i></span><b class="price-value">5 950 000 ₽</b></span></div><div class="line-tit">Год выпуска</div><div class="line-val">2020</div><div class="line-tit">Расположение</div><div class="line-val line-val-bubble"><span>ёМосква и еще <span class="ext-city-list" data-cf-modified-876940278ac4b007a0e51228-="" onclick="if (!window.__cfRLUnblockHandlers) return false; openTBC()">31 город</span></span><div class="trade__bubble-cities"><div class="closeBtn" data-cf-modified-876940278ac4b007a0e51228-="" onclick="if (!window.__cfRLUnblockHandlers) return false; closeTBC()">+</div><div class="trade__bubble-cities-sign"></div><p>Предложение актуально для следующих городов:</p><div class="trade__bubble-cities__list"><ul><li>Белгород</li><li>Владивосток</li><li>Волгоград</li><li>Вологда</li><li>Воронеж</li><li>Екатеринбург</li><li>Иркутск</li><li>Казань</li><li>Киров</li> <li>Краснодар</li><li>Красноярск</li><li>Липецк</li><li>Москва</li><li>Набережные Челны</li><li>Нижний Новгород</li><li>Новокузнецк</li><li>Новосибирск</li><li>Пенза</li><li>Пермь</li><li>Пятигорск</li><li>Ростов-на-Дону</li><li>Самара</li><li>Санкт-Петербург</li><li>Саратов</li><li>Симферополь</li><li>Ставрополь</li><li>Сургут</li><li>Томск</li><li>Тюмень</li><li>Уфа</li><li>Чебоксары</li><li>Челябинск</li></ul></div></div></div> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")