re = /(.+?CS.{2})/i
str = 'HLI6Ch60000Ch500C0Ch46400Ch30000Ch21888Ch10E79CS07LCU3Ch37880Ch27800Ch16480CS8CA00000000000000000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end