package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^,]+)`)
var str = `Christopher Columbus Avenue, lorem ipsum dolores est`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}