const regex = /\bCFV\[1161170\](?!\[UNIQUE\]).*?\[VALUE\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bCFV\\[1161170\\](?!\\[UNIQUE\\]).*?\\[VALUE\\]', 'g')
const str = `CFV[1161170][UNIQUE][VALUE] CFV[1161170][5pGKucpYSQ][VALUE] CFV[1161170][jk9Gh79SK2z][VALUE]
CFV[1161170][UNIQUE][jk9Gh79SK2z][VALUE]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}