#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z][a-z]+:"
Local $sString = "<ul>" & @CRLF & _
"<li>Frankfurt/Main</li>" & @CRLF & _
"<li>Germany</li>" & @CRLF & _
"<li>Architect: Coop Himmelb(l)au</li>" & @CRLF & _
"<li>2008 - 2014</li>" & @CRLF & _
"<li>Client: European Central Bank ECB</li>" & @CRLF & _
"<li>Engineering Firm: ARGE IFFT-ML / Prof. Schott – Prof. Lange, Arup GmbH, AS&P – Albert Speer & Partner GmbH, B + G Ingenieure, Bollinger & Grohmann GmbH with Grontmij BGS Ingenieurgesellschaft mbH</li>" & @CRLF & _
"<li>Contractor: Züblin AG</li>" & @CRLF & _
"<li>Photographer: © European Central Bank/Robert Metsch</li>" & @CRLF & _
"</ul>" & @CRLF & _
"<p> </p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")