re = /^(?!.*(?=(.))((.{9})+|(.(?!(?3)*$))+|(?(?=.(...)*$)(.(?!(.{27})*$)){7}|.)+)\1)/
str = '618792354837265941723154869956817423281543697374926185549638712165479238492381576'
# Print the match result
str.match(re) do |match|
puts match.to_s
end