re = /^(?!\-)(?:[a-zA-Z\d\-]{0,62}[a-zA-Z\d]\.){1,126}(?!\d+)[a-zA-Z\d]{1,63}(:)\d+$/
str = 'aspmx.l.google.com:0'
# Print the match result
str.match(re) do |match|
puts match.to_s
end