$re = '/START (.*) END/m';
$str = 'START START JIBBERISH START END END SADASDASDAD END
START START END END
START START END END
START END
START in between END
START START END START END END END START END START END START END END
START START END START END START END START END START END END';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);