$re = '/%X?INCLUDE (\w+).\1$/';
$str = '%XINCLUDE hola.hola
%XINCLUDE hola.hola';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);