$re = '/^(0[1-9]|[12][0-9]|3[01])[/]([01][12])[/]([1-9][0-9]{3})$/';
$str = '12/12/2052';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);