# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^m=[a-zA-Z]*) ([0-9]{0,5})"
test_str = ("v=0\n"
"o=bob 2808844564 2808844564 IN IP4 host.biloxi.example.com\n"
"s=\n"
"c=IN IP4 host.biloxi.example.com\n"
"t=0 0\n"
"m=audio 49174 RTP/AVP 0\n"
"a=rtpmap:0 PCMU/8000\n"
"m=video 49170 RTP/AVP 32\n"
"a=rtpmap:32 MPV/90000\n\n\n"
"m=audio 49170 RTP/AVP 0\n"
"a=rtcp:53020\n\n"
"m=audio 49170 RTP/AVP 0\n"
"a=rtcp:53020 IN IP4 126.16.64.4\n\n"
"m=audio 49170 RTP/AVP 0\n"
"a=rtcp:53020 IN IP6 2001:2345:6789:ABCD:EF01:2345:6789:ABCD")
subst = "$1 5060"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.