use strict;
my $str = '[products-tab collection="frontpage,new,all-1" title="BEST SELLING" nav="true" style="product-loop-swatch" rows="2" items="8" header="style-1"]
[products-deal product="apple-iphone-se,armani-exchange-brown-leather-watch-ax2181" title="DEAL OF THE DAY"]
[blog blog="news" desc="If you are interested in the latest articles in the industry, take a sneak peek at our blog. You’ve got nothing to loose!" style="style-2"]
[products-tab collection="frontpage,new,all-1" title="BEST SELLING" nav="true" style="product-loop-swatch" rows="2" items="8" header="style-1"]
';
my $regex = qr/\[[^\[]*\]/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}