package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*) \((.*)\) (.*)`)
var str = `Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}