package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\bSTDMETHOD_?\b([\s\S]*?)\bPURE\b)`)
var str = `STDMETHOD_(MyFunc)(
D2D1_SIZE_U size,
_In_opt_ CONST void *srcData,
) PURE;
STDMETHOD(MyFunc2)(
_In_opt_ CONST void *srcData2,
UINT32 pitch2,
) PURE;\
STDMETHOD_(void, GetFactory)(
_Outptr_ ID2D1Factory **factory
) CONST PURE;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}