$re = '/^(.).(?!\1).+$/m';
$str = 'X9K3 V3Z5
A4A9 R5R1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);