$re = '/^(?:[&\/#-][A-Za-z0-9]{3,4})+$/m';
$str = '&ACK2-ASD3#RERT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);