#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "gamers_online.*\s*(\d+),?(\d+),?(\d+)"
Local $sString = "[...]" & @CRLF & _
"" & @CRLF & _
"<div id="about_header_area" class=" global">" & @CRLF & _
" <div class="about_area_inner_wrapper">" & @CRLF & _
" <div id="about_monitor_video">" & @CRLF & _
" <video width="100%" height="auto" autoplay muted loop playsinline poster="https://cdn.fastly.steamstatic.com/store/about/videos/about_hero_loop_web.png">" & @CRLF & _
" <source src="https://cdn.fastly.steamstatic.com/store/about/videos/about_hero_loop_web.webm" type="video/webm">" & @CRLF & _
" <source src="https://cdn.fastly.steamstatic.com/store/about/videos/about_hero_loop_web.mp4" type="video/mp4">" & @CRLF & _
" </video>" & @CRLF & _
" <div id="about_monitor_video_gradient"></div>" & @CRLF & _
" </div>" & @CRLF & _
" <div id="about_header">" & @CRLF & _
" <div id="about_greeting">" & @CRLF & _
" <div class="about_greeting_header">" & @CRLF & _
" <div class="steam_logo"><img src="https://cdn.fastly.steamstatic.com/store//about/logo_steam.svg" alt="The logo for Steam"></div>" & @CRLF & _
" <div class="about_subtitle">Steam is the ultimate destination for playing, discussing, and creating games.</div>" & @CRLF & _
" <div class="online_stats">" & @CRLF & _
" <div class="online_stat">" & @CRLF & _
" <div class="online_stat_label gamers_online">online</div>" & @CRLF & _
" 36,426,658 </div>" & @CRLF & _
" <div class="online_stat">" & @CRLF & _
" <div class="online_stat_label gamers_in_game">playing now</div>" & @CRLF & _
" 10,289,777 </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <div class="about_install_wrapper">" & @CRLF & _
" <div class="about_install win ">" & @CRLF & _
" <a href="https://cdn.fastly.steamstatic.com/client/installer/SteamSetup.exe" class="about_install_steam_link">Install Steam</a>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="installer_list">" & @CRLF & _
" <div class="available_platforms">" & @CRLF & _
" Also available on:" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <a class="platform_icon" href="https://cdn.fastly.steamstatic.com/client/installer/steam.dmg">" & @CRLF & _
" <img src="https://cdn.fastly.steamstatic.com/store/about/icon-macos.svg">" & @CRLF & _
" </a>" & @CRLF & _
" <a class="platform_icon" href="https://cdn.fastly.steamstatic.com/client/installer/steam.deb">" & @CRLF & _
" <img src="https://cdn.fastly.steamstatic.com/store/about/icon-steamos.svg">" & @CRLF & _
" </a>" & @CRLF & _
" <a class="platform_icon" href="https://support.google.com/chromebook?p=steam_on_chromebook">" & @CRLF & _
" <img src="https://cdn.fastly.steamstatic.com/store/about/icon-chromeos.svg">" & @CRLF & _
" </a>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="learn_more_btn">" & @CRLF & _
" <a href="#about_games_cta_area" class="smooth_scroll">" & @CRLF & _
" Learn more <span class="down_arrow"></span>" & @CRLF & _
" </a>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")