package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-G]{1})(\#|b{1})?`)
var str = `D#
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}