$re = '/(?=[\x00-\x7F])[^a-zA-Z0-9]/m';
$str = '££££A$££0#$%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);