using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&\[[^]]+]$";
string input = @"[Product].[Product Catalog].[Product].&[50]&[53]&[DE]&[1ST_HQ]&[50_54_36]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}