$re = '/\b[A-Z0-9]{6}\b/m';
$str = 'I have a string 09A4N5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);