$re = '/\bI\'?\s*a?m\b/';
$str = 'I\'m, Im, Iam, I am';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);