re = /(?:\?|&)(.+?)=([A-Z+%0-9]+)/im
str = 'http://mydomain/Forwards?searchValue[]=Nike+Webstore&searchValue[]=Bodyman&category_filter[]=Animals+%26+Pet+Supplies&category_filter[]=Fashion&country_filter[]=Aland+Islands&country_filter[]=American+Samoa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end