use strict;
my $str = 'ABCDFE908787';
my $regex = qr/([A-Z]+)[0-9]+/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";