use strict;
my $str = 'ROM1234567
ROMM1234567
ROM123456789
input should not work:
RO1234567
RO123456
ROM123456
ROM123456789012';
my $regex = qr/^(?=[A-Z]{3,}[0-9]{7,}$)[A-Z0-9]{10,14}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}