# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"=(?!\d+(?:\.\d+)?(?:,|$))([^\",\n]+)"
test_str = "speed=36.2448,course=331.35,gps_time=2021-11-22T00:43:22.678Z,fix=1,message_source=device_gps,period_km=0.436,location=Middle of no where,x=3.2"
subst = "=\"\\1\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.