const regex = /^(Armadale|Fremantle|Butler|Mandurah|Midland|Thornlie)\D+(?![0-9]{2}-[0-9]{3}-[0-9]{2}\D+)\d+-\d+-\d+\D+2[0-9]{4}\D+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(Armadale|Fremantle|Butler|Mandurah|Midland|Thornlie)\\D+(?![0-9]{2}-[0-9]{3}-[0-9]{2}\\D+)\\d+-\\d+-\\d+\\D+2[0-9]{4}\\D+$', '')
const str = `Armadale Joe Bloggs 22-333-22 20001 Whitfords to Butler`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}