re = /([0-9]{4}-[0-9]{2}-[0-9]{2})\s([0-9]{2}:[0-9]{2}:[0-9]{2})/
str = '2012-01-13 11:13:57 57 12.11.31.34 301 TCP_NC_MISS'
# Print the match result
str.match(re) do |match|
puts match.to_s
end