#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^|\s+)(SIN|SX|RIC|OK)(\s+|$)"
Local $sString = "16M2 - SIN - 49.000 KM - SENS - A/C - n.d. - FROM: - MATRIC.: n.d. - GEAR: n.d. - COD.PROD.RIC.: n.d. - NR.PLATE: " & @CRLF & _
"14I2 - OK - 20.000 KM - A/C - n.d. - FROM: - MATRIC.: n.d. - GEAR: n.d. - COD.PROD.RIC.: n.d. - NR.PLATE: " & @CRLF & _
"11A0 - SIN - 55.000 KM - SQUARE - SENS - A/C" & @CRLF & _
"16H0 - n.d. - n.d. - FROM: - MATRIC.: n.d. - GEAR: n.d._n.d. marce - COD.PROD.RIC.: n.d. - NR.PLATE: " & @CRLF & _
"14N1 - SIN - n.d. - FROM: - MATRIC.: n.d. - GEAR: n.d._n.d. marce - COD.PROD.RIC.: n.d. - NR.PLATE: - STEEL" & @CRLF & _
"16D2 - SIN - n.d. - FROM: - MATRIC.: n.d. - GEAR: n.d._n.d. marce - COD.PROD.RIC.: n.d. - NR.PLATE: " & @CRLF & _
"SX 100000 KM 15K2" & @CRLF & _
"SIN - 15D1" & @CRLF & _
"16P0 - OK - n.d. - FROM: - MATRIC.: n.d. - GEAR: n.d._n.d. marce - COD.PROD.RIC.: n.d. - NR.PLATE: " & @CRLF & _
"16H0 - SIN - n.d. - FROM: - MATRIC.: n.d. - GEAR: n.d._n.d. marce - COD.PROD.RIC.: n.d. - NR.PLATE: " & @CRLF & _
"16I1 SIN" & @CRLF & _
"14K1 - SIN - n.d. - FROM: - MATRIC.: n.d. - GEAR: n.d._n.d. marce - COD.PROD.RIC.: n.d. - NR.PLATE: " & @CRLF & _
"SX 14E2" & @CRLF & _
"SX 16D1 NO TURBO" & @CRLF & _
"SX 110000 KM 15M1" & @CRLF & _
"16O2 - SIN " & @CRLF & _
"15J1 - SIN" & @CRLF & _
"16L1 SIN DAMAGED" & @CRLF & _
"16P2 - SIN - DAMAGED" & @CRLF & _
"SX 15E2" & @CRLF & _
"SX 9D2" & @CRLF & _
"SIN - 130.000 KM - 16J1" & @CRLF & _
"OK 13A0" & @CRLF & _
"SX 16M0" & @CRLF & _
"OK 11A1" & @CRLF & _
"OK 12V1" & @CRLF & _
"SX 105CV 15P1" & @CRLF & _
"OK 105CV 15O2" & @CRLF & _
"14A2 - SIN" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")