re = /(?:https?:\/\/)?(?:www.)?(?:youtube.com|youtu.be)\/(?:watch\?)?v=([^\s]+)/m
str = 'Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry\'s standard dummy text ever since the 1500s, https://www.youtube.com/watch?v=7TL02DA5MZM when an unknown printer took a galley of type and scrambled it to make a type'
# Print the match result
str.match(re) do |match|
puts match.to_s
end