re = /^[1-9][A-Z]{2}([1-9][0-9][0-9]|[0-9][1-9][0-9]|[0-9][0-9][1-9])$/m
str = '1BC111
1BC011
1BC101
1BC001'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end