$re = '/[0-9]{3]/m';
$str = '301
2302139';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);