$re = '/^.+\.com$/m';
$str = 'this.com
hello.be
byebye.co.uk
google.com
abc.org
altavista.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);