$re = '/(\d{4})(\d{1,20})(\d{4})/m';
$str = '001421000213412341241212312321123123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);