using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{\K(?:[^,}]*,){13}";
string substitution = @"";
string input = @"{1,1,0,0,0,4,0,0,0,0,20,4099,4241,706,706,714,714,817,824,824,824,2,2,2,2,1,1,1,1},";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}