package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1}(-|\s)\d{3}(-|\s)\d{5}(-|\s)\d{1}`)
var str = `0 000 00000 0
0-000-00000-0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}