const regex = /^[a-z0-9]([a-z0-9]*[-_]*[a-z0-9]+)*@([a-z0-9]*[-_\.]?[a-z0-9]+)+[\.][a-z]{2,3}([\.][a-z]{2})?$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9]([a-z0-9]*[-_]*[a-z0-9]+)*@([a-z0-9]*[-_\\.]?[a-z0-9]+)+[\\.][a-z]{2,3}([\\.][a-z]{2})?$', 'i')
const str = `1sf_-SSSdf-_-__--___d3@china.SDDutl-ook.cn`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}