using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/?(?:\b(?!(?:div|tag)\b))([a-zA-Z0-9]+).*?>";
string input = @"<div> <diva a> <a> <h9>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}