# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(warning|error|note|help)(?:\[(.*)\])?\: (.*)\s+--> (.*):(\d+):(\d+)\n(?:((?:.+\n)+)\.+)?(?:[\d\s]+\|.*)*((?:\s+=.*)+)?"
test_str = ("Compiling sample v0.1.0 (file:///home/sample/src/sample.rs)\n"
"error: cannot borrow immutable local variable `buffer` as mutable\n"
"--> src/sample.rs:29:32\n"
"|\n"
"26 | let buffer = String::new();\n"
"| ------ use `mut buffer` here to make mutable\n"
"...\n"
"29 | while ifile.read_line(&mut buffer).unwrap() > 0 {\n"
"| ^^^^^^ cannot borrow mutably\n\n"
"error: cannot borrow immutable local variable `buffer` as mutable\n"
"--> src/sample.rs:39:9\n"
"|\n"
"26 | let buffer = String::new();\n"
"| ------ use `mut buffer` here to make mutable\n"
"...\n"
"39 | buffer.clear();\n"
"| ^^^^^^ cannot borrow mutably\n\n"
"error[E0384]: re-assignment of immutable variable `buffer`\n"
"--> src/sample.rs:30:9\n"
"|\n"
"26 | let buffer = String::new();\n"
"| ------ first assignment to `buffer`\n"
"...\n"
"30 | buffer = buffer.replace(\"\\n\", \"\");\n"
"| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ re-assignment of immutable variable\n\n"
"error: aborting due to 3 previous errors\n\n"
"error: Could not compile `sample`.\n\n"
"To learn more, run the command again with --verbose.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.