// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\d\s\n].*\n").unwrap();
let string = "1
00:00:01.876 --> 00:00:02.709
<v Instructor>We can go back now</v>
2
00:00:02.709 --> 00:00:05.042
to our web server checklist.
3
00:00:06.410 --> 00:00:08.722
We've already seen better ways to organise our code
4
00:00:08.722 --> 00:00:11.545
into reusable pieces with modules,
5
00:00:11.545 --> 00:00:13.315
we've seen ways to deal with files,
6
00:00:13.315 --> 00:00:15.940
both synchronous and asynchronous,
7
00:00:15.940 --> 00:00:16.773
and buffers,
8
00:00:16.773 --> 00:00:18.325
both the built-in Node one
9
00:00:18.325 --> 00:00:20.380
and the ES6 buffers,
10
00:00:20.380 --> 00:00:22.485
and we've seen a way to deal with work";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}