re = /^(?<your_field>\w+)/m
str = 'Risk - 24 Hour Risk Threshold Exceeded - Rule
Endpoint - machine with possible malware - fffff
Network - Possible SQL injection - Rule'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end