$re = '/\d{4}[a-zA-Z]{2}/';
$str = '1004AV
9387be
3827BE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);