# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?(3)|\)*)(?>\((?2)*(()(?1))?(\)|$)|0|\"[^\n\"]*.?|(1|(2|(3|4(?1))(?1))(?1))(?1)))*\)*$"
test_str = ("Truthy:\n\n"
"0\n"
")\n"
"(\n"
"\"\n"
"()\n"
"\"\"\n"
"10\n"
"400010\n"
"210010\n"
"(\"\")00\n"
"3\"\"\"\"\"\n"
"2(2(2(0)0)0)0\n"
"2\"010\"\"44)()4\"\n"
")31(0)0(20102010\n"
"())2)1))0\"3())\"))\n"
"3(\"4321(\"301(0)21100\"4\")\"123\"00)40\"121\"31000\"\"01010\n\n"
"Falsy:\n\n"
"1\n"
"1(310\n"
"12(010\n"
"4\"00010\"\n"
"3120102100\n"
"20(2((0)(0)))\n"
"2(2(2(0)0)0)01)\n"
"4(0102)00)00000\n"
"2\"00\"(\"00\"2(\"\"))\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.