$re = '~\$\d+[\d.]*\b\s*\Z~';
$str = '
$99.99
$94.99
$129.99
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);