$re = '/(word1)[^w]*(?:w(?!ord2)[^w]*)*(word2)?.*?(word3)/m';
$str = 'word1 word2 word3
word1 word3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);